Backup Radar: Investigating Issue
Incident Report for ScalePad
Resolved
This incident has been resolved.
Posted Jan 14, 2025 - 17:34 EST
Monitoring
An issue with an expired certificate was identified and resolved. We keep monitoring for now.
Posted Jan 14, 2025 - 14:43 EST
Investigating
We are investigating reports of a problem with Backup Radar. We appreciate your patience and will provide updates as more information becomes available.
Posted Jan 14, 2025 - 14:29 EST
This incident affected: Backup Radar.