Contract / Agreement sync in Lifecycle Manager

Incident Report for ScalePad

Resolved

This issue has been resolved. Please note that contract/agreement data may take up to 24 hours to appear in your Lifecycle Manager account while processing completes.
Posted Jun 19, 2026 - 16:40 EDT

Investigating

We are investigating an issue affecting contract and agreement data in Lifecycle Manager for some partners. Impacted users may see contracts or agreements older than 2 years missing from the Agreements page, or sync attempts showing no new or updated contracts. Our team is actively working to identify the cause and restore normal behaviour.
Posted Jun 19, 2026 - 12:58 EDT
This incident affected: Lifecycle Manager.