Lifecycle Manager: Investigating Datto RMM Sync Failures

Incident Report for ScalePad

Resolved

This incident has been resolved.
Posted Jun 19, 2026 - 11:28 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 19, 2026 - 10:10 EDT

Identified

We have identified an issue affecting Datto RMM syncs in Lifecycle Manager since the evening of June 16. Some partners may see failed syncs or stale data while we work on a resolution.
Posted Jun 18, 2026 - 14:32 EDT
This incident affected: Lifecycle Manager.