Lifecycle Manager: Sync Delays

Incident Report for ScalePad

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 13:14 EDT

Monitoring

We are seeing data syncing correctly and monitoring the situation for all partners.
Posted Jul 14, 2026 - 11:52 EDT

Identified

We’ve identified a challenge where a subset of Lifecycle Manager integrations haven’t automatically synced since 07/11. Some syncs are also not running when manually triggered.

We’ve identified the cause and are urgently working on a resolution. We expect syncs to start running for all affected accounts by the end of today, with updated data in all accounts by this evening, or tomorrow at the very latest for larger syncs.
Posted Jul 13, 2026 - 12:29 EDT
This incident affected: Lifecycle Manager.