Quoter: Integration Sync Delays

Incident Report for ScalePad

Resolved

This incident has been resolved.
Posted Jun 18, 2026 - 14:05 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 18, 2026 - 11:11 EDT

Investigating

We are investigating reports of delayed integration pushes affecting some PSA integrations, including Autotask, ConnectWise, and Halo.

We will provide an update once we have more information.
Posted Jun 18, 2026 - 09:05 EDT
This incident affected: Quoter.