Schedule Reports & Hardware Reports including Agreements page can’t be used

Incident Report for ScalePad

Resolved

This incident has been resolved.
Posted Aug 20, 2026 - 14:12 EDT

Update

We are investigating an issue affecting report creation and delivery. Scheduled Reports & Agreements may display a blank screen, and the Hardware Lifecycle Report option from the Client Summary page may not open. Customers may be unable to create or send these reports.
Our team is working to identify the cause and restore normal functionality. We will provide another update as more information becomes available.
Posted Aug 20, 2026 - 11:42 EDT

Investigating

We are investigating an issue affecting report creation and delivery. Scheduled Reports may display a blank screen, and the Hardware Lifecycle Report option from the Client Summary page may not open. Customers may be unable to create or send these reports.
Our team is working to identify the cause and restore normal functionality. We will provide another update as more information becomes available.
Posted Aug 20, 2026 - 11:12 EDT
This incident affected: Lifecycle Manager.