Lifecycle Manager: View Contacts Page

Incident Report for ScalePad

Resolved

This incident has been resolved.
Posted May 06, 2026 - 19:33 EDT

Investigating

We’re aware of an issue preventing access to the Contacts page in Lifecycle Manager.
We’re working urgently on a resolution and will update here as soon as we know more.
Posted May 06, 2026 - 17:33 EDT
This incident affected: Lifecycle Manager.