Partner accounts are currently unable to view Agreement details from the agreements list page

Incident Report for ScalePad

Resolved

This has been resolved and is working correctly now.
Posted Jun 23, 2026 - 03:12 EDT

Investigating

Partner accounts are currently unable to view Agreement details from the agreements list page in Lifecycle Manager.
We are working on a fix and deploying shortly.
Posted Jun 22, 2026 - 13:26 EDT
This incident affected: Lifecycle Manager.