Sync Issues with MS365 Multi-Tenant Integration

Incident Report for ScalePad

Resolved

We’ve released a new MS365 Multi-Tenant integration that resolves the challenges faced by some partners using the previous integration.

To add the new integration, here are the steps:
https://help.lifecyclemanager.com/hc/en-us/articles/45103723278107-Integrating-with-Microsoft-365-Multi-Tenant

If you run into issues, or if data still doesn’t appear as expected after completing the setup, please work through the troubleshooting steps in this article: https://help.lifecyclemanager.com/hc/en-us/articles/46603439704603-Resolving-Microsoft-365-Multi-Tenant-Sync-issues
Posted Feb 18, 2026 - 18:48 EST

Investigating

A subset of partners may encounter errors when syncing certain tenants or specific tenant data from our MS365 Multi-Tenant integration. Our team is treating this as urgent and actively working to identify the root cause and implement a resolution. For now, if you encounter this error, use our MS365 Single-Tenant integration for key clients.
Posted Jan 12, 2026 - 15:39 EST
This incident affected: Lifecycle Manager.