Backup Radar: Unable to access app

Incident Report for ScalePad

Resolved

We have not seen any further errors following our fix so we are closing this incident at this time.

Thank you very much for your patience.
Posted Jun 17, 2025 - 15:54 EDT

Monitoring

An error in our certificate renewal process caused Backup Radar to be inaccessible for partners in both US and EU regions.

We have deployed a fix to the affected services and the app should now be accessible again.
Posted Jun 17, 2025 - 14:42 EDT
This incident affected: Backup Radar.