Backup Radar: Datto Screenshot Results Discrepancy

Incident Report for ScalePad

Update

We are seeing a discrepancy between Datto API results and the Datto UI for Screenshot verifications. The Datto API is returning Failure for Screenshot backups, while the Datto UI shows them as Successful. Backup Radar ingests API results, so affected jobs may appear as Failed even when the Datto UI shows success.

Current status:
This appears to be upstream with Datto. We are engaged with Datto Support and awaiting their update. The timing and detail of further updates will depend on information provided by Datto. Backup Radar systems in general are operating as expected.
Posted Oct 02, 2025 - 16:54 EDT

Investigating

We've received reports that the Datto API integration is malfunctioning.

We are currently investigating the issue and will provide more information as it becomes available.
Posted Sep 30, 2025 - 11:36 EDT
This incident affects: Backup Radar.